System Outage EvoEyes
Incident Report for EvoCount GmbH
Resolved
The Issue has been resolved
Posted Jun 18, 2022 - 14:35 CEST
Investigating
EvoEyes is experiencing an issue at the moment. We are currently investigating it and will provide further updates as they are available.
Posted Jun 18, 2022 - 14:15 CEST
This incident affected: EvoEyes Portal and EvoCount Core Services.